Contato: marcofernando71@gmail.com

SGP
Programação e Desenvolvimento

Está precisando de alguma ajuda em programação, desenvolvimento em C, C#, C++, CSS, HTML, JavaScript, PHP, AJAX, Jquery, Laravel, codeigniter, Python, Portugol, NodeJS, MongoDB, Mysql, Postegre entre outras duvidas entre em contato.

Desenvolvimento de sites, projetos, softwares, blogs, ajudas nas áreas acadêmicas de trabalhos e projetos até provas entre em contato a nossa equipe irá te ajudar.

Email: marcofernando71@gmail.com

Programação em C e C++

Duvidas, trabalhos, Projetos, Softwares, sites, blogs ou precisando de alguma ajuda entre em contao e faça seu orçamento.: marcofernando71@gmail.com

HTML E CSS

Duvidas, trabalhos, Projetos, Softwares, sites, blogs ou precisando de alguma ajuda entre em contao e faça seu orçamento.: marcofernando71@gmail.com

PHP

Duvidas, trabalhos, Projetos, Softwares, sites, blogs ou precisando de alguma ajuda entre em contao e faça seu orçamento.: marcofernando71@gmail.com

TAMPLATES PARA SITES E BLOGS

Duvidas, trabalhos, Projetos, Softwares, sites, blogs ou precisando de alguma ajuda entre em contao e faça seu orçamento.: marcofernando71@gmail.com

Pages

sexta-feira, 12 de abril de 2019

Programa para Calcular o Fatorial em Java utilizando o netebens.

Programa em Java que vai calcular o Fatorial de um número informado pelo usuário.
















Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Algoritmo em JavaScript de como montar uma tabuada simples.

Programa que vai receber um número informado pelo usuário e calcular sua tabuada.
<script>
var x;
var n=parseInt(prompt("Digite número:"));
for (x=1;x<=10;x++) {
document.write ("<p>"+x);
document.write ("X"+n);
document.write ("=");
var p=n*x;
document.write (p);
}
</script>

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Algoritmo em PHP para calcular número primo passo a passo

Exemplo simples como calcular se um número é Primo ou não em PHP.

arquivo index.php











arquivo primo.php





























Duvidas e Trabalhos para fazer entre em Contato:
Email: marcofernando71@gmail.com

segunda-feira, 14 de janeiro de 2019

Programa para achar Número Primo em Java.

Programa em Java para achar se o número informado pelo usuário e Primo ou Não.


























Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Algoritmo C++, para calcular os produtos da tabela.

1 - Faça um programa que receba:

  • O código do produto comprado
  • A quantidade comprada do produto

Calcule e mostre:


  • O preço unitário do produto comprado, seguindo a tabela 1.
  • O preço total da nota
  • O valor do desconto, seguindo tabela 2 e aplicado sobre o preço total da nota
  • O preço final da nota depois do desconto.


TABELA 1
Código
Preço
1 a 10
R$ 10,00
11 a 20
R$ 15,00
21 a 30
R$ 20,00
31 a 40
R$ 30,00

TABELA  2
Preço total da nota
% de Desconto
Até R$ 250,00
5%
Entre R$ 250,00 e R$ 500,00
10%
Acima de R$ 500,00
15%
#include <iostream>
#include <cstdlib>
#include <time.h>
#include<stdio.h>
#include<string.h>
#include<math.h>



using namespace std;
int main (void){
int codigoP;
   float Quant, preco_total,preco_desconto,preco1,preco2,preco3,preco4;
   cout<<"Digite o código do produto=";
   cin>>codigoP;
   cout<<"Digite a quantidade comprada=";
   cin>>Quant;
   if ((codigoP>=1) && (codigoP<=10)){
       preco1= Quant * 10.00;
   } else if ((codigoP>=11) && (codigoP<=20)) {
       preco2= Quant * 15.00;
   } else if((codigoP>=21) && (codigoP<=30)){
       preco3= Quant * 20.00;
   } else((codigoP>=31) && (codigoP<=40)){
       preco4= Quant * 30.00;
   }
   preco_total=preco1+preco2+preco3+preco4;
   if (preco_total<=250){
       preco_desconto=preco_total-preco_total*0.05;
   }else if((preco_total>250)&&(preco_total<=500){
       preco_desconto=preco_total-preco_total*0.1;
   }else(preco_total>500){

preco_desconto=preco_total-preco_total*0.15;

   }
   cout<<"Preço total = "<<preco_total;
   cout<<"Preço final da nota = " <<preco_desconto;
system ("pause");
}

___________________________________________________________________________________

 2 - Faça um programa que receba o valor de um carro e mostre uma tabela com os seguintes dados: preço final, quantidade de parcelas e valor da parcela. Considere os seguintes:



  • O preço final para comprar a vista tem desconto de 20%
  • A quantidade de parcelas pode ser: 6,12,18,24,30,36,42,48,54 e 60.
  • Os percentuais de acréscimo encontram-se na tabela a seguir:

Quantidade de Parcelas
Percentual de acréscimo sobre o Preço Final
6
3%
12
6%
18
9%
24
12%
30
15%
36
18%
42
21%
48
24%
54
27%
60
30%

#include <iostream>

#include <cstdlib>

#include <time.h>

#include<stdio.h>
#include<string.h>
#include<math.h>

using namespace std;
int main (void){
int parcelas, i;   
float valor, preco, val_parcela;    
cout<<"Informe o valor do carro: ";    
cin>>valor;   
cout<<"Preço final a vista: %.2f\n", valor * 0.8;  
for (i=1; i<=10; i++) {    
preco = valor * (valor + (i*3)/100);       
parcelas = 6 * i;
val_parcela = preco / parcelas;       
cout<<"Preço: "<<preco<<"\tQtde parcelas: "<<parcelas<<"\tValor da parcela: \n"<<val_parcela;   
}   

system ("pause");
}

  ___________________________________________________________________________________

  3 - Foi feita uma pesquisa entre os habitantes de uma região. Foram coletados os dados de idade, sexo (M/F) e salário. Faça um programa que calcule e mostre:
  • A média dos salários do grupo
  • A maior e menor idade do grupo
  • A quantidade de mulheres com salário até R$ 200,00
  • A idade e o sexo da pessoa que possui o menor salário


Finalize a entrada de dados ao ser digitada uma idade negativa.


#include <iostream>
#include <cstdlib>
#include <time.h>
#include<stdio.h>
#include<string.h>
#include<math.h>


using namespace std;
int main (void){

int idade,maior_idade, menor_idade, Quant=0, quant_mulheres_200=0, idade_menor;

   float salario,soma=0,menor_salario=-1;

   char sexo, sexo_menor;

   cout<<"Digite a sua idade=";

   cin>>idade;

   menor_idade = maior_idade = idade;

   while (idade>=0){

       cout<<"Digite o sexo=";

   cin>>sexo;

   cout<<"Digite o seu salario=";

   cin>>salario;

   quant++;

   soma+=salario;

   if(menor_idade> idade){

       menor_idade = idade;

   } else if (maior_idade<idade){

       maior_idade=idade;

   }else if (sexo=='F'&& salario<=200){

       quant_mulheres_200++;

   }else if ((menor_salario==-1)||(salario< menor_salario)){

       menor_salario = salario;

       sexo_menor = sexo;

       idade_menor = idade;
}

   cout<<"Informe a idade:";
   cin>>idade;
   }
   if (quant>0){
       printf("Média dos salarios do grupo: "<< soma/quant;
       cout<<" Maior idade do grupo: "<< maior_idade;
       cout<<"Menor idade do grupo: "<< menor_idade;
     cout<<"Quantidade de mulheres com salário até R$ 200,00: "<< qtd_mulheres_200;
     cout<<"Pessoa que possui o menor salário. Idade : "<<idade_menor<<"\tSexo: "<<sexo_menor<<"\tSalário: "<<menor_salario<<;
  }
  else {
     cout<<"Não existem habitantes";
}

system ("pause");
}

______________________________________________________________________________________________

4- Em uma eleição presidencial existem 4 candidatos. Os votos são informados por meio de código. Os códigos utilizados são:


Código
Votos
1,2,3,4
Votos para os respectivos candidatos
5
Voto nulo
6
Voto em branco

Faça um programa que calcule e mostre:

  • O total dos votos para cada candidato
  • O total de votos nulos
  • O total de votos em branco
  • A percentagem de votos nulos sobre o total de votos
  • A percentagem de votos em branco sobre o total de votos
Para finalizar o conjunto de votos, tem-se o valor zero e, para códigos inválidos, o programa deverá mostrar uma mensagem.


   #include <iostream>

#include <cstdlib>
#include <time.h>
#include<stdio.h>
#include<string.h>
#include<math.h>

using namespace std;
int main (void){
int Prime, secon, terce, quart, nulo, branco,totalvotos;
   float porcentnulo, porcentbranco, x;
   cout<<"Digite 1,2,3,4 para escolher seu canditado:";
   cout<<"5 para nulo, 6 para voto em branco ou 0 (ZERO) para encerrar o programa:";
   cin>>x;
  if ((x >= 0) && (x < 7)) {
  } else if ((x<0)&&(x>0)) {
  totalvotos=totalvotos + 1;
  } else if (x == 1) {
  prime=prime + 1;
  printf  ("Voce escolheu o primeiro candidato.";
  }else if (x == 2){
   secon=secon + 1;
   cout<<"Voce escolheu o segundo candidato.";
  } else if (x == 3){
   terce=terce + 1;
   cout<<"Voce escolheu o terceiro candidato.";
   } else if (x == 4){
   quart=quart + 1;
   cout<<"Voce escolheu o quarto candidato.";
   } else if (x == 5){
   nulo=nulo + 1;
cout<<"Seu voto foi nulo.";
   } else if (x == 6){
   branco=branco + 1;
   cout<<"Seu voto foi em branco.";
   } else if {
   cout<<"Os numeros digitados devem estar entre 1 e 6";
   cout<<"Voce digitou 0(ZERO)";
   }
   else (x == 0){
   cout<<"Voce encerrou o programa logo abaixo consta os resultados.";
   }
   if (totalvotos<0) && (totalvotos>0){
   porcentnulo=(nulo * 100) / totalvotos;
   porcentbranco= (branco * 100) /  totalvotos;
   }
   cout<<"Candidato numero 1 tem: "<<prime<<" voto(s).";
   cout<<"Candidato numero 2 tem: "<<secon<<" voto(s).";
   cout<<"Candidato numero 3 tem: "<<terce<<" voto(s).";
   cout<<"Candidato numero 4 tem: "<<quart<<" voto(s).";
   cout<<"Teve : "<<nulo<<" voto(s) nulo.";
   cout<<"Teve : "<<branco<<" voto(s) em branco.";
   cout<<"A porcentagem de votos nulos sao: "<<porcentnulo<<" %.";
   cout<<"A porcentagem de votos em branco sao: "<<porcentbranco<<" %.";
system ("pause");
}


   Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Algoritmo em Portugol completo para calcular o determinante de uma matriz passo a passo.

Podemos calcular o determinante de qualquer matriz desde que essa seja quadrada, ou seja, que a matriz tenha o mesmo número de linhas e de colunas (seja uma matriz de ordem n x n).

algoritmo "determinante"
var
     m, cont,linha,linha1,coluna: inteiro
    cont1, cont2:real
    mat:vetor [1..5,1..5] de real
    
inicio
       para linha de 1 ate 3 passo 1 faca
           para coluna de 1 ate 3 passo 1 faca
                escreva("Informe um número: ")
                leia(mat[linha,coluna])
           fimpara
      fimpara

       cont2 <- 0
       cont <- 0
       cont1 <- 0
      para linha de 1 ate 3-1 faca
          se(mat[linha,linha] = 0)entao
                 para linha1 de linha ate 3 faca
                      se(mat[linha1,linha] <> 0)entao
                           para coluna de 1 ate 3 faca
                                cont2 <- mat[linha, coluna]
                                 mat[linha, coluna]<-mat[linha1, coluna]
                                 mat[linha1, coluna] <- cont2
                           fimpara
                           linha1 <- 3
                      fimse
                 fimpara
                 cont<- cont +1
          fimse
          
        se(mat[linha,linha] <> 0)entao
             para linha1 de linha+1 ate 3 faca
                    cont1 <- (-1.0) * mat[linha1, linha] /  mat[linha,linha]
                    para coluna de linha ate 3 faca
                          mat[linha1, coluna] <- mat[linha1, coluna] + (cont1 * mat[linha, coluna])
                    fimpara
             fimpara
        fimse
          
      fimpara
      cont2 <- 1.0
       para linha de 1 ate 3 faca
            cont2 <- cont2 *  mat[linha, linha]
       fimpara
       
       escreva("Determinante:")
    se(cont mod 2 = 0)entao
        escreva( cont2)
    senao
        escreva(-1.0 * cont2)
    fimse

fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: Email: marcofernando71@gmail.com
 
Copyright © 2018 todos os direitos reservados. Contato: marcofernando71@gmail.com

Está precisando de alguma ajuda em programação, desenvolvimento em C, C#, C++, CSS, HTML, JavaScript, PHP, AJAX, Jquery, Laravel, codeigniter, Python, Portugol, NodeJS, MongoDB, Mysql, Postegre entre outras duvidas entre em contato. Desenvolvimento de sites, projetos, softwares, blogs, ajudas nas áreas acadêmicas de trabalhos e projetos até provas entre em contato a nossa equipe irá te ajudar.