Pages

terça-feira, 28 de junho de 2016

Programas básicos em Algoritmo Parte 3

O usuário vai informar o salario e conforme o valor vai ser o reajuste.

algoritmo "01"
var
   salario:real
inicio
   escreva("Informe o seu salario")
   leia(salario)
   se(salario < 500)entao
      escreva("O seu salario vai se de: ",salario+(salario*0.15))
   fimse
   se(salario >=500)ou(salario <=1000)entao
      escreva("O seu salario vai se de: ", salario+(salario*0.10))
   senao
      escreva("O seu salario vai se de: ",salario+(salario*0.05))
   fimse
fimalgoritmo

Informar 02 números e depois um terceiro e verificar se está na faixa numérica dos números

algoritmo "faixaNumerica"
var
   n1,n2,n3,aux:inteiro
inicio
   escreva("Informe o primeiro número")
   leia(n1)
   escreva("Informe o segundo número")
   leia(n2)
   se(n1<n2)entao
      escreva("Informe o terceiro numero: ")
      leia(n3)
      se(n1<n3)e(n2>n3)entao
           escreva("O terceiro numero esta dentro da faixa")
      senao
           escreva("O terceiro numero não esta dentro da faixa")
      fimse
   senao
        aux<-n1
        n1<-n2
        n2<-aux
        escreva("Informe o terceiro numero")
        leia(n3)
        se(n1<n3)e(n2>n3)entao
             escreva("O terceiro numero esta dentro da faixa")
        senao
             escreva("O terceiro numero não esta dentro da faixa")
        fimse
   fimse

fimalgoritmo

Informar 04 números e verificar se são divisíveis por 2 e 3.

algoritmo "divisiveis"
var
     n1,n2,n3,n4:inteiro
inicio
      escreva("Informe o primeiro numero")
      leia(n1)
      escreva("Informe o segundo numero")
      leia(n2)
      escreva("Informe o terceiro numero")
      leia(n3)
      escreva("Informe o quarto numero")
      leia(n4)
      se(n1 mod 2 = 0) e (n1 mod 3 = 0)entao
            escreval("O 1º numero e divisivel",n1)
      fimse
      se(n2 mod 2 = 0) e (n2 mod 3 = 0)entao
            escreval("O 2º numero e divisivel",n2)
      fimse
      se(n3 mod 2 = 0) e (n3 mod 3 = 0)entao
            escreval("O 3º numero e divisivel",n3)
      fimse
      se(n4 mod 2 = 0) e (n4 mod 3 = 0)entao
            escreval("O 4º numero e divisivel",n4)
      fimse

fimalgoritmo

Informar as 04 notas Bimestrais e verificar se o Aluno foi aprovado ou não.

algoritmo "notasAprovacao"
var
      n1,n2,n3,n4,md,ne,mf:real
inicio
      escreva("Informe a primeira nota")
      leia(n1)
      escreva("Informe a segunda nota")
      leia(n2)
      escreva("Informe a terceira nota")
      leia(n3)
      escreva("Informe a quarta nota")
      leia(n4)
      md<-(n1+n2+n3+n4)/4
      se(md>=7)entao
          escreva("O aluno foi aprovado direto com a nota",md)
      senao
           escreva("Informe a nota do exame")
           leia(ne)
           mf<-(md+ne)/2
           se(mf>=5)entao
              escreva("O aluno foi aprovado no exame com a nota",mf)
           senao
                escreva("O aluno foi reprovado no exame com a nota",mf)
           fimse
      fimse

fimalgoritmo

0 comentários:

Postar um comentário