Pages

terça-feira, 28 de junho de 2016

Calcular o fibonacci em Algoritmo.

Vai receber um valor e fazer o calculo do fibonacci.

algoritmo "fibonacci"
var
   n,cont,fib,ant,atual:inteiro
inicio
      cont <-1
      escreva("Informe um numero")
      leia(n)
      repita
            se(cont = 1) entao
                fib<-1
                ant<-0
                atual<-1
            senao
                fib<- ant + atual
                ant<-atual
                atual<-fib
            fimse
             escreval(cont,": fibonacci eh: ",fib)
            cont<-cont+1
      ate cont>n
fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

0 comentários:

Postar um comentário