Pages

terça-feira, 28 de junho de 2016

Ordenar um vetor em ordem crescente em Algoritmo.

Vai preencher um vetor de 10 posições com valores aleatórios e ordenar em ordem crescentes.

algoritmo "08"
var
   vet:vetor[1..10] de inteiro
   cont,cont1,aux:inteiro
inicio
      para cont de 1 ate 10 passo 1 faca
           escreva("Informe um número: ")
           leia(vet[cont])
      fimpara
      para cont de 1 ate 10 passo 1 faca
           para cont1 de 1 ate 9 passo 1 faca
              se (vet[cont1] > vet[cont1+1])entao
                 aux<-vet[cont1]
                 vet[cont1]<-vet[cont1+1]
                 vet[cont1+1]<-aux
              fimse
           fimpara
      fimpara
      
      para cont de 1 ate 10 passo 1 faca
           escreval(cont,": ",vet[cont])
      fimpara
fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

0 comentários:

Postar um comentário