Pages

quarta-feira, 29 de junho de 2016

Programa que utilize uma sub-rotina de Função ou Procedimento para calcular a série de Fibonacci de N termos

Programa que utilize uma sub-rotina para calcular a série de Fibonacci de N termos. A série de Fibonnacci é formada pela sequência: 1, 1, 2, 3, 5, 8, 13, 21, 34, ... etc. Está série caracteriza-se pela soma de um termo posterior com o seu anterior subsequente. Apresentar o resultado.
Usando Função:

algoritmo "Fibonacci"
funcao FIBO(TERMO:inteiro):inteiro
var
   ant,atual,fib,cont:inteiro
inicio
      para cont de 1 ate TERMO passo 1 faca
           se(cont = 1) entao
                   ant<-0
                   atual<-1
                   fib<-atual
           senao
                fib<-ant+atual
                ant<-atual
                atual<-fib
           fimse
      fimpara
     retorne fib
fimfuncao
var
   num:inteiro
inicio
      escreva("Informe um número para calcular o fibonacci: ")
      leia(num)
      escreva("O Fibonacci eh: ",FIBO(num))
fimalgoritmo


Usando Procedimento:

algoritmo "fibonacci"
procedimento FIBO(TERMO:inteiro)
var
   ant,atual,fib,cont:inteiro
inicio
      para cont de 1 ate TERMO passo 1 faca
           se(cont = 1) entao
                   ant<-0
                   atual<-1
                   fib<-atual
           senao
                fib<-ant+atual
                ant<-atual
                atual<-fib
           fimse
      fimpara
      escreva("O Fibonacci eh: ",fib)
fimprocedimento
var
   num:inteiro
inicio
      escreva("Informe um número para calcular o fibonacci: ")
      leia(num)
      FIBO(num)

fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

0 comentários:

Postar um comentário