Pages

terça-feira, 28 de junho de 2016

Programas básico usando Vetor em algoritmo.

Vai receber 03 números dentro de um vetor e realizar a soma deles.

algoritmo "somaVetor"
var
  vet:vetor[1..3] de inteiro
  cont,soma:inteiro
inicio
      soma<-0
      para cont de 1 ate 3 passo 1 faca
           escreval("Informe um número")
           leia(vet[cont])
           soma<-soma+vet[cont]
      fimpara
      escreval("A soma dos numeros eh:",soma)
fimalgoritmo

Vai receber 10 números e verificar quantos números são pares e quantos impares.

algoritmo "parImparVetores"
var
    vet:vetor[1..10]de inteiro
    cont,par,impar:inteiro
inicio
     par<-0
     impar<-0
     para cont de 1 ate 10 passo 1 faca
           escreval("Informe um número")
           leia(vet[cont])
           se(vet[cont]mod 2 = 0)entao
               par<-par+1
           senao
               impar<-impar+1
           fimse
     fimpara
     escreva("Par: ",par)
     escreval("Impar:",impar)

fimalgoritmo

Vai receber dois números e fazer a soma e armazenar num vetor

algoritmo "soma"
var
   vet1,vet2,vet3:vetor[1..5] de inteiro
   cont:inteiro
inicio
    para cont de 1 ate 5 passo 1 faca
         escreva("Informe o primeiro número")
         leia(vet1[cont])
         escreva("informe o segundo número")
         leia(vet2[cont])
         vet3[cont]<-vet1[cont]+vet2[cont]
    fimpara
    para cont de 1 ate 5 passo 1 faca
         escreval(cont," posição a soma eh: ",vet3[cont])
    fimpara

fimalgoritmo


Vai receber 03 números e fazer a multiplicação do seu valor pela quantidade da posição do vetor lembrando que vai começar a contar o vetor a partir 1.
algoritmo "multiplicacaoVetor"
var
    vet,vet1:vetor[1..3] de inteiro
    cont,cont1,soma:inteiro
inicio

     para cont de 1 ate 3 passo 1 faca

          escreval(cont, ":Informe um número: ")
          leia(vet[cont])
          soma<-1
          para cont1 de 1 ate cont passo 1 faca
               soma<- soma*vet[cont]
          fimpara
          vet1[cont]<-soma
     fimpara
     
     para cont de 1 ate 3 passo 1 faca
          escreval(cont," : ",vet1[cont])
     fimpara

fimalgoritmo

Vai preencher um vetor de 05 posições e exibir em ordem inversa.

algoritmo "inversaVetor"
var
   vet,vet1:vetor[1..5] de inteiro
   cont,cont1:inteiro
inicio
      cont1<-1
      para cont de 1 ate 5 passo 1 faca
           escreva(cont,": Informe um número: ")
           leia(vet[cont])
      fimpara
      para cont de 5 ate 1 passo -1 faca
              vet1[cont1]<-vet[cont]
             cont1<-cont1+1
      fimpara
       para cont de 1 ate 5 passo 1 faca
           escreval(cont," : ",vet1[cont])
      fimpara

fimalgoritmo

Vai pedir para preencher um vetor de 05 posições e calcular o seus FIBONACCI.

algoritmo "FIBONACCI"
var
     vet,vet1:vetor[1..5] de inteiro
     cont,cont1,fibo,ant,atual:inteiro
inicio
      para cont de 1 ate 5 passo 1 faca
           escreval(cont,": informe um número: ")
           leia(vet[cont])
           para cont1 de 1 ate vet[cont] passo 1 faca
                se(cont1 = 1)entao
                     fibo<-1
                     ant<-0
                     atual<-fibo
                senao
                    fibo<-ant+atual
                    ant<-atual
                    atual<-fibo
                fimse
           fimpara
           vet1[cont]<-fibo
      fimpara
      para cont de 1 ate 5 passo 1 faca
           escreval("Posição:", cont," o FIBONACCI: ",vet1[cont])
      fimpara

fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

0 comentários:

Postar um comentário