Pages

terça-feira, 28 de junho de 2016

Programas básicos em Algoritmo Parte 2

Vai pedir para informar o nome e o sexo e dar uma saudação.

algoritmo "sexo"
var
      nome:caracter
      sexo:inteiro
inicio
      escreva("Informe o seu nome: ")
      leia(nome)
      escreva("Informe o seu sexo 1-masculino 2-femenino: ")
      leia(sexo)
      se(sexo = 1)entao
         escreva("Bem vindo senhor: ",nome)
      fimse
      se(sexo = 2)entao
         escreva("Bem vindo senhora: ",nome)
      fimse
fimalgoritmo


Informar dois números e achar a diferença do maior pelo menor

algoritmo "numero"
var
   n1,n2:inteiro
inicio
   escreva("Informe o primeiro numero")
   leia(n1)
   escreva("Informe o segundo numero")
   leia(n2)
   se(n1>n2)entao
     escreva("A diferença dos números eh: ",n1-n2)
   fimse
   se(n2>n1)entao
       escreva("A diferença dos números eh: ",n2-n1)
   fimse
fimalgoritmo

Vai pedir um número e apresentar ele positivo se for negativo deixar positivo.

algoritmo "positivo"
var
   n1:inteiro
inicio
   escreva("Informe um numero: ")
   leia(n1)
   se(n1>0)entao
      escreva("O número eh: ",n1)
   fimse
   se(n1<0)entao
      escreva("O número eh: ",n1*(-1))
   fimse
fimalgoritmo


Informa 4 números e vai verificar qual são divisíveis por 3.

algoritmo "divisiveis "
var
   n1,n2,n3,n4:inteiro
inicio
   escreva("Informe o primeiro numero: ")
   leia(n1)
   escreva("Informe o segundo numero: ")
   leia(n2)
   escreva("Informe o terceiro número: ")
   leia(n3)
   escreva("Informe o quarto número: ")
   leia(n4)
   se(n1%3=0)entao
      escreva("o primeiro número: ",n1)
   fimse
   se(n2%3=0)entao
      escreval("o segundo número: ",n2)
   fimse
   se(n3%3=0)entao
      escreval("o terceiro número: ",n3)
   fimse
   se(n4%3=0)entao
      escreval("o quarto número: ",n4)
   fimse

fimalgoritmo

Informar um número e achar se é par ou impar.

algoritmo "parImpar"
var
  n1:inteiro
inicio
   escreva("Informe um numero: ")
   leia(n1)
   se(n1%2=0)entao
      escreva("O número e Par")
   fimse
   se(n1%2<>0)entao
      escreva("O número e Impar")
   fimse

fimalgoritmo

Informar 05 números e achar qual é o maior e qual é o menor.
algoritmo "maiorMenor"
var
   n1,n2,n3,n4,n5,maior,menor:inteiro
inicio
   escreva("Informe o primeiro número: ")
   leia(n1)
   escreva("Informe o segundo número: ")
   leia(n2)
   escreva("Informe o terceiro número: ")
   leia(n3)
   escreva("Informe o quarto número: ")
   leia(n4)
   escreva("Informe o quinto número: ")
   leia(n5)
   maior<-n1
   menor<-n1
   se(n2>maior)entao
      maior<-n2
   fimse
   se(n3>maior)entao
      maior<-n3
   fimse
   se(n4>maior)entao
      maior<-n4
   fimse
   se(n5>maior)entao
      maior<-n5
   fimse
   
   se(n2<menor)entao
      menor<-n2
   fimse
   se(n3<menor)entao
      menor<-n3
   fimse
   se(n4<menor)entao
      menor<-n4
   fimse
   se(n5<menor)entao
      menor<-n5
   fimse
   escreval("O maior número eh: ",maior)
   escreva ("O menor número eh: ",menor)
fimalgoritmo

Informar 03 números e ordenar eles em ordem crescente ou decrescente conforme o desejo do usuário.
algoritmo "crescenteDecrescente "
var
   n1,n2,n3,opc:inteiro
inicio
   escreva("Informe o primeiro número")
   leia(n1)
   escreva("Informe o segundo número")
   leia(n2)
   escreva("Informe o terceiro número")
   leia(n3)
   escreva("1-crescente 2-decrescente")
   leia(opc)
   se(opc = 1)entao
       se(n2>=n1) e (n3>=n2) entao
           escreva(n1,n2,n3)
       fimse
       se(n2>=n3) e (n3>=n1)entao
           escreva(n1,n3,n2)
       fimse
       se(n3>=n1) e (n1 >=n2)entao
           escreva(n2,n1,n3)
       fimse
       se(n2>= n1) e (n1 >= n3)entao
           escreva(n3,n1,n2)
       fimse
       se(n1>= n3) e (n3 >= n2)entao
           escreva(n2,n3,n1)
       fimse
       se(n1>= n2) e (n2>= n3)entao
           escreva(n3,n2,n1)
       fimse
       se(n1= n2) e (n2= n3)entao
           escreva(n1,n2,n3)
       fimse
   fimse
   se(opc = 2)entao
         se(n2<=n1)e ( n3<=n2)entao
              escreva(n3,n2,n1)
         fimse
         se(n2<=n3) e (n3<=n1)entao
              escreva(n2,n3,n1)
         fimse
         se(n3<=n1)e( n1 <=n2)entao
              escreva(n3,n1,n2)
         fimse
         se(n2<= n1) e (n1 <= n3)entao
              escreva(n2,n1,n3)
         fimse
         se(n1<= n3) e (n3 <= n2)entao
              escreva(n1,n3,n2)
         fimse
         se(n1<= n2) e (n2<= n3)entao
              escreva(n1,n2,n3)
         fimse
         se(n1=n2)e (n2=n3)entao
              escreva(n3,n2,n1)
         fimse
   fimse
   se(opc<1)ou(opc>2)entao
        escreva("Opção inválida!")
   fimse

fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com.

0 comentários:

Postar um comentário