Pages

terça-feira, 28 de junho de 2016

Programas básicos em Algoritmo Parte 4

Vai somar os 100 primeiros números usando laços de repetição.

algoritmo "soma"
var
 n,cont:inteiro
inicio
      n<-0
      cont<-0
      enquanto n<=100 faca
           cont<-cont+n
           n<-n+1
      fimenquanto
      escreva("A soma eh: ",cont)
fimalgoritmo

Vai somar todos os números pares de 1 a 500.

algoritmo "somaPares"
var
   n,cont:inteiro
inicio
      n<-1
      cont<-0
    enquanto n<=500 faca
        se(n mod 2 =0)entao
           escreval("",n)
           cont<-cont+n
        fimse
       n<-n+1
    fimenquanto
    escreva("A soma dos numeros eh: ",cont)

fimalgoritmo

Vai mostrar todos os números impares de 0 a 200.

algoritmo "numerosImpares"
var
    n:inteiro
inicio
   n<-1
   enquanto n<=200 faca
       se(n mod 2 <> 0)entao
            escreval(n)
       fimse
       n<-n+1
   fimenquanto

fimalgoritmo

Vai apresentar as potencias de base 3 variando de 0 a 15
algoritmo "potencias"
var
  x,y,poten:inteiro
inicio
   x<-0
   y<-1
   poten<-1
   enquanto x<=15 faca
       enquanto y<=x faca
            poten<-poten*3
            y<-y+1
       fimenquanto
       escreval("potencia de base: ",x," eh: ",poten)
       x<-x+1
   fimenquanto

fimalgoritmo

Vai receber a base e o expoente e fazer o seu calculo da Potencia.
algoritmo "calcularPotencia"
var
     b,ex,x,y,poten:inteiro
inicio
      poten<-1
      x<-0
      y<-0
      escreva("Informe uma base: ")
      leia(b)
      escreva("Informe um expoente: ")
      leia(ex)
      enquanto x<=ex faca
          enquanto y<x faca
             poten<-poten * b
             y<-y+1
          fimenquanto
          escreval("a Potencia do expoente: ",x," eh:",poten)
          x<-x+1
      fimenquanto

fimalgoritmo

Vai receber valor positivo e saia até receber um valor negativo e apresentar o maior e o menor número digitado.

algoritmo "maiorMenor"
var
      n,menor,maior:inteiro
inicio
      n<-0
      menor<-0
      maior<-0
      enquanto n>=0 faca
          escreval("Digite um número: ")
          leia(n)
          se(n>maior)entao
             maior<-n
          fimse
          se(n<menor)entao
             menor<-n
          fimse
      fimenquanto
      escreva("O maior número eh: ",maior)
      escreva("O menor numero eh: ",menor)

fimalgoritmo

Vai achar a media de 10 números digitados.

algoritmo "media"
var
   n,cont:real
   x:inteiro
inicio
      x<-1
      cont<-0
      enquanto x<=3 faca
           escreva("Digite um número ")
           leia(n)
           cont<-cont+n
           x<-x+1
      fimenquanto
      escreva("A media eh: ",cont/3)

fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

0 comentários:

Postar um comentário