Pages

terça-feira, 28 de junho de 2016

Programas básicos em Algoritmo Parte 5.

Vai receber um numero e vai pedir se vai querer informar mais números no fim mostrar a soma e a media.

algoritmo "somaMedia"
var
   sair,cont,soma,n:inteiro
inicio
      cont<-0
      soma<-0
      repita
            escreva("Informe um numero:")
            leia(n)
            soma<-soma+n
            cont<-cont+1
            escreva("deseja continuar 1-sim 0-nao")
            leia(sair)
            limpatela
      ate sair = 0
      escreval("A soma eh: ",soma)
      escreva("A media eh: ",soma/cont)
fimalgoritmo

Vai receber dois números e verificar se pode ser feita a divisão caso não poder informar outro número.

algoritmo "divisao"
var
   n1,n2,cont:inteiro

inicio
      cont<-0
      escreva("Informe dois numeros: ")
      leia(n1,n2)
      se (n2 <> 0)entao
          repita
             n1<- n1-n2
             cont<-cont+1
          ate n1 < n2
          escreva(" a divisao eh : ",cont)
      senao
           escreva("Não existe divisão por zero")
      fimse

fimalgoritmo

Vai pedir para informar a base e o expoente e calcular a exponenciação e depois se o usuário deseja realizar um novo calculo.

algoritmo "exponenciação"
var
  b,ex,sair,cont,expot:inteiro
inicio
      repita
            escreva("informe a base e o expoente")
            leia(b,ex)
            cont<-0
            expot<-1
            repita
                  expot<-expot*b
                  cont<-cont+1
            ate cont=ex
            escreval("A expotenciação eh: ",expot)

            escreva("deseja continuar 1-sim 0-não")
            leia(sair)
             limpatela
      ate sair=0
fimalgoritmo 


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com.

0 comentários:

Postar um comentário