Pages

terça-feira, 28 de junho de 2016

Programas básicos em Algoritmos Parte 1.

Mostre uma mensagem "ola mundo" em algoritmo.

algoritmo "01"
var
inicio
      escreva("ola mundo")
fimalgoritmo


Transformar temperatura em Cº em Fahrenheit.

algoritmo "02"
var
   tempC,tempF:real
inicio
   escreva("Informe a temperatura em graus Cº")
   leia(tempC)
   tempf<-tempC * 1.8 + 32
   escreva("\nA Temperatura em Fahrenheit eh:",tempF)

fimalgoritmo


Transformar temperatura Fahrenheit em graus Cº.

algoritmo "03"
var
   tempC,tempF:real
inicio
   escreva("Informe a Temperatura em Fahrenheit")
   leia(tempF)
   tempc<- (tempF - 32) / 1.8
   escreva("A temperatura em Cº: ",tempC)
fimalgoritmo

//°C = (°F – 32) / 1,8


Programa que vai receber o Valor da Prestação em atraso e o juros e calcular a nova prestação.

algoritmo "04"
var
   valor,taxa,prestacao:real
   tempo:inteiro
inicio
   escreva("Informe o valor da prestação")
   leia(valor)
   escreva("Informe a taxa de juros")
   leia(taxa)
   escreva("Informe o tempo em atraso em mês")
   leia(tempo)
   prestacao<- valor + (valor * (taxa/100)) * tempo
   escreva("O valor da Prestação em atraso e de: ",prestacao)

fimalgoritmo

O usuário vai digitar dois valores e troca de valores entre variáveis.

algoritmo "05"
var
   a,b,aux:inteiro
inicio
   escreva("Informe o valor para A: ")
   leia(a)
   escreva("Informe o valor para B: ")
   leia(b)
   aux<-a
   a<-b
   b<-aux
   escreva("A:",a)
   escreva("B: ",b)

fimalgoritmo

Apresentar o quadrado da diferença do primeiro pelo segundo.

algoritmo "06"
var
   n1,n2,dif:inteiro
inicio
   escreva("informe o primeiro numero")
   leia(n1)
   escreva("informe o segundo numero")
   leia(n2)
   dif<-n1-n2
   escreva("O quadrado da diferença e: ",dif * dif)

fimalgoritmo

Achar o valor em dollar.

algoritmo "07"
var
   cotDol,valReal,valorDol:real
inicio
    escreva("Informe o valor da cotação do Dollar: ")
    leia(cotDol)
    escreva("Informe a quantidade de dinheiro em Dollar: ")
    leia(valorDol)
    valReal<- cotDol * valorDol
    escreva("O valor em R$: ",valReal)

fimalgoritmo

Soma dos quadrados de 3 números
algoritmo "08"
var
   n1,n2,n3,quadrado:inteiro
inicio
   escreva("Informe o primeiro numero")
   leia(n1)
   escreva("Informe o segundo numero")
   leia(n2)
   escreva("Informe o segundo numero")
   leia(n3)
   quadrado <-(n1*n1)+(n2*n2)+(n3*n3)
   escreva("A soma dos quadrados eh: ",quadrado)

fimalgoritmo

Quadrado da soma de 3 números.

algoritmo "09"
var
   n1,n2,n3,quadrado:inteiro
inicio
   escreva("Informe o primeiro numero")
   leia(n1)
   escreva("Informe o segundo numero")
   leia(n2)
   escreva("Informe o terceiro numero")
   leia(n3)
   quadrado <- (n1+n2+n3)*(n1+n2+n3)
   escreva("O quadrado da soma dos numero eh: ",quadrado)

fimalgoritmo

Um programa que vai calcular a porcentagem dos votos de 3 candidato numa eleição.

algoritmo "10"
var
    candA,candB,candC,branco,nulo,totalEleitores:inteiro
    votosValidos:real
inicio
    escreva("Informe a quantidade de voto para o Canditado A: ")
    leia(candA)
    escreva("Informe a quantidade de voto para o Canditado B: ")
    leia(candB)
    escreva("Informe a quantidade de voto para o canditado C: ")
    leia(candC)
    escreva("Informe a quantidade de votos em brancos: ")
    leia(branco)
    escreva("Informe a quantidade de votos nulos: ")
    leia(nulo)
    totalEleitores <- candA + candB + candC + branco + nulo
    votosValidos <- (totalEleitores / 100)  *(candA + candB + candC)
    escreval("O total de Eleitores eh: ",totalEleitores)
    escreval("A Porcentual de votos validos: ",votosValidos)
    escreval("O Porcentual de votos para canditado A: ",(totalEleitores / 100)  *candA )
    escreval("O Porcentual de votos para canditado B: ",(totalEleitores / 100)  *candB )
    escreval("O Porcentual de votos para canditado C: ",(totalEleitores / 100)  *candC )
    escreval("O Porcentual de votos para canditado Branco: ",(totalEleitores / 100)  *branco )
    escreval("O Porcentual de votos para canditado Nulo: ",(totalEleitores / 100)  *nulo)

fimalgoritmo



Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

0 comentários:

Postar um comentário