Pages

terça-feira, 28 de junho de 2016

Uma calculadora básica em Algoritmo.

Vai receber dois valores e perguntar qual das operações básicas matemática irá ser realizada.

algoritmo "calculadora "
var
   n1,n2:real
   opc:inteiro
inicio
    escreva("Informe o primeiro número")
    leia(n1)
    escreva("Informe o segundo número")
    leia(n2)
    escreval("Informe a operação desejada")
    escreval("1-somar 2-subtrair 3-mutliplicação 4-divisão")
    leia(opc)
    se(opc = 1)entao
       escreva("A soma dos números eh: ",n1+n2)
    fimse
    se(opc = 2)entao
       escreva("A subtração dos números eh: ",n1-n2)
    fimse
    se(opc = 3)entao
       escreva("A mutiplicação dos números eh: ",n1*n2)
    fimse
    se(opc = 4)entao
        se(n2 = 0)entao
          escreva("Não exite divisão por zero")
        fimse
        se(n2>0)entao
           escreva("A divisão dos números eh: ",n1/n2)
        fimse
    fimse
fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

0 comentários:

Postar um comentário