Pages

sexta-feira, 1 de julho de 2016

Algoritmo para calcular a Potencia de um número usando Função ou procedimento.

Desenvolva um algoritmos de programa que crie uma sub-rotina para calcular e apresentar o valor
de uma potência de um número qualquer. Ou seja, ao informar para a sub-rotina o número e sua
potência, deverá ser apresentado o seu resultado. Por exemplo, se for mencionado no programa
principal a sub-rotina POTENCIA(2,3), deverá ser apresentado o valor 8.

algoritmo "POTENCIA"
funcao POTENCIA(BASE,EXPO:INTEIRO):inteiro
var
   cont,poten:inteiro
inicio
      poten<-1
      para cont de 1 ate EXPO passo 1 faca
           poten<-poten*BASE
      fimpara
      retorne poten
fimfuncao
var
   bas,ex:inteiro
inicio
      escreva("Informe a base e o expoente: ")
      leia(bas,ex)
      escreva("A potencia eh: ",POTENCIA(bas,ex))
fimalgoritmo

Usando procedimento

algoritmo "POTENCIA"
procedimento POTENCIA(BASE,EXPO:INTEIRO)
var
   cont,poten:inteiro
inicio
      poten<-1
      para cont de 1 ate EXPO passo 1 faca
           poten<-poten*BASE
      fimpara
      escreva("A potencia eh: ",poten)
fimprocedimento
var
   bas,ex:inteiro
inicio
      escreva("Informe a base e o expoente: ")
      leia(bas,ex)
      POTENCIA(bas,ex)
fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: Email: marcofernando71@gmail.com

0 comentários:

Postar um comentário