Pages

sexta-feira, 1 de julho de 2016

Algoritmo para fazer conversão de temperatura usando função ou procedimento.

Elaborar um programa que com o uso de sub-rotina do tipo função apresente o valor de uma
temperatura em graus Celsius. O programa deverá ler a temperatura em graus Fahrenheit e
apresentá-la convertida em graus Celsius. Sendo que a fórmula de conversão é C <- (F - 32) * (5/9).

algoritmo "temperatura"
funcao FAHRENHEIT(F:real):real
var
   cels:real
inicio
      cels<-(F - 32) * (5/9)
      retorne cels
fimfuncao
var
   tempF:real
inicio
      escreva("Informe a temperatura em Fahrenheit: ")
      leia(tempF)
      escreva("A temperatura em Celsius eh: ",FAHRENHEIT(tempF))
fimalgoritmo


Usando procedimento.

algoritmo "temperatura"
procedimento FAHRENHEIT(F:real)
var
   cels:real
inicio
      cels<-(F - 32) * (5/9)
      escreva("A temperatura em Celsius eh: ",cels)
fimprocedimento
var
   tempF:real
inicio
      escreva("Informe a temperatura em Fahrenheit: ")
      leia(tempF)
      FAHRENHEIT(tempF)
fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: Email: marcofernando71@gmail.com.

0 comentários:

Postar um comentário