Pages

sexta-feira, 1 de julho de 2016

Algoritmo para fazer a conversão usando Função ou procedimento.

Elaborar um programa que por meio de sub-rotina efetue a apresentação do valor da conversão em
real (R$) de um valor lido em dólar (US$). Deverá ser solicitado por meio do programa principal o valor da cotação do dólar e a quantidade de dólar disponível.


algoritmo "CONVERSAO" 
funcao CONVERSAO(DOLAR,COTAC:real):real
var
   valorReal:real
inicio
      valorReal<-DOLAR * COTAC
      retorne valorReal
fimfuncao
var
   qtdDolar,valDolar:real
inicio
      escreva("Informe a quantidade de dólar e o valor da cotação: ")
      leia(qtdDolar,valDolar)
      escreva("O valor em real eh R$:",CONVERSAO(qtdDolar,valDolar))
fimalgoritmo

Usando procedimento


algoritmo "CONVERSAO"
procedimento CONVERSAO(DOLAR,COTAC:real)
var
   valorReal:real
inicio
      valorReal<-DOLAR * COTAC
      escreva("O valor em real eh R$:",valorReal)
fimprocedimento
var
   qtdDolar,valDolar:real
inicio
      escreva("Informe a quantidade de dólar e o valor da cotação: ")
      leia(qtdDolar,valDolar)
      CONVERSAO(qtdDolar,valDolar)
fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: Email: marcofernando71@gmail.com

0 comentários:

Postar um comentário