Pages

sexta-feira, 1 de julho de 2016

Algoritmo que some o quadrado de três números em função ou procedimento

Elaborar um programa que efetue a leitura de três valores (A, B e C) e apresente como resultado
final o quadrado da soma dos três valores lidos.

algoritmo "somaQuadrado"
funcao QUADRADO(A,B,C:inteiro):inteiro
var
   soma:inteiro
inicio
      soma<-(A*A)+(B*B)+(C*C)
      retorne soma
fimfuncao
var
   n1,n2,n3:inteiro
inicio
      escreva("Informe três valores: ")
      leia(n1,n2,n3)
      escreva("O quadrados dos números eh: ",QUADRADO(n1,n2,n3))
fimalgoritmo

Usando procedimento

algoritmo "somaQuadrado"
procedimento QUADRADO(A,B,C:inteiro)
var
   soma:inteiro
inicio
      soma<-(A*A)+(B*B)+(C*C)
      escreva("O quadrados dos números eh: ",soma)
fimprocedimento
var
   n1,n2,n3:inteiro
inicio
      escreva("Informe três valores: ")
      leia(n1,n2,n3)
      QUADRADO(n1,n2,n3)
fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: Email: marcofernando71@gmail.com

0 comentários:

Postar um comentário