Pages

sexta-feira, 1 de julho de 2016

Jogo de Logica da Raposa e a Galinha em Algoritmo

Um fazendeiro está levando uma raposa, uma galinha e um saco de grãos para casa. Para chegar lá, ele precisa atravessa um rio, mas ele pode, apenas, levar um item consigo de cada vez. Se a raposa for deixada sozinha com a galinha, ela comerá a galinha. Se a galinha for deixada sozinha com os grãos, ela comerá os grãos. Como o fazendeiro poderá atravessar o rio sem que nada seja comido?

ProgramaJogoLogico
var
   galinha,milho,raposa,voce,op,aux,cont:inteiro
inicio
      cont<-1
      op<-0
      galinha<- 1
      milho<-1
      raposa<-1
      voce<-1
      enquanto op<>2 faca
         escreva(" ______________________________________________________________________")
         escreva("|             ********** BEM VINDO AO JOGO **********                  |")
         escreva("|                                                                      |")
         escreva("| VOCE ESTA LEVANDO UMA RAPOSA, UMA GALINHA E UM SACO DE MILHO DA      |")
         escreva("| MARGEM 1 PARA MARGEM 2, VOCE PRECISA ATRAVESSAR A RAPOSA UMA GALINHA |")
         escreva("| E UM SACO DE MILHO PARA MARGEM 2, MAS VOCE PODE APENAS LEVAR UM ITEM |")
         escreva("| CONSIGO DE CADA VEZ. SE A RAPOSA FOR DEIXADA SOZINHA COM A GALINHA,  |")
         escreva("| ELA COMERA A GALINHA. SE A GALINHA FOR DEIXADA SOZINHA COM O SACO DE |")
         escreva("| MILHO, ELA COMERA O MILHO. COMO VOCE PODERA ATRAVESSAR MARGEM-2      |")
         escreva("| SEM QUE NADA SEJA COMIDO?                                            |")
         escreva("|                                                                      |")
         escreva("|  1 - JOGAR                                                           |")
         escreva("|                                                                      |")
         escreva("|  2 - NAO JOGAR                                                       |")
         escreva("|______________________________________________________________________|")
         escreva("INSIRA A OPCAO")
         leia(op)
         escolha (op)
                 caso 1
                       enquanto cont=1  faca
                            escreva("MARGEM 1              MARGEM 2")
                            se(galinha=1)entao
                                  escreva("galinha")
                        senao
                              escreva("                      galinha")
                           fimse

                           se(milho=1)  entao
                                  escreva("SACO DE MILHO")
                              senao
                                     escreva("                      SACO DE MILHO")
                              fimse

                        se(raposa=1) entao
                                  escreva("RAPOSA")
                              senao
                                     escreva("                      RAPOSA")
                              fimse

                       
se(voce=1) entao
                        escreva("VOCE")
                        senao
                                     escreval("                      VOCE")
                             fimse

                             escreva("_________________________________________")
                             escreva("| **** ESCOLHA QUEM VOCE VAI LEVAR ****  |")
                             escreva("|                                        |")
                             escreva("|        1 - ATRAVESSAR GALINHA          |")
                             escreva("|                                        |")
                             escreva("|        2 - ATRAVESSAR SACO DE MILHO    |")
                             escreva("|                                        |")
                             escreva("|        3 - ATRAVESSAR RAPOSA           |")
                             escreva("|                                        |")
                             escreva("|        4 - ATRAVESSAR SOZINHO          |")
                             escreva("|_______________________________________ |")
                             leia(aux) 
                             se(aux = 1)e( galinha <> voce)ou(aux = 2)e(milho <> voce)ou(aux = 3)e(raposa <> voce) entao
                                     escreva("VOCE SO PODE LEVAR QUEM ESTA NA MESMA MARGEM QUE VOCE.")
                             senao

                                  se(aux = 1)entao
                                     se (galinha = 1) entao
                                          galinha <- 2
                                     senao
                                           galinha <- 1
                                     fimse

                                     se(voce = 1) entao
                                             voce <- 2
                                     senao
                                             voce <- 1
                                     fimse

                                   fimse

                                   

     se (aux = 2)entao
                                          se(milho = 1) entao
                                              milho <- 2
                                          senao
                                              milho <- 1
                                          fimse
                                          se(voce = 1)entao
                                              voce <- 2
                                          senao
                                              voce <- 1
                                          fimse
                                   fimse

                                   se (aux = 3) entao
                                          se(raposa = 1)entao
                                             raposa <- 2
                                          senao
                                              raposa <- 1
                                          fimse
                                          se(voce = 1)entao
                                              voce <- 2
                                          senao
                                              voce <- 1
                                          fimse
                                   fimse

                                   se (aux = 4)entao
                                          se(voce = 1)entao
                                              voce <- 2
                                          senao
                                              voce <- 1
                                           fimse
     senao
                                      escreva (" OPCAO INVALIDA! ")
                                   fimse

                                   se(raposa = galinha) e (galinha <> voce) entao
                                            escreva(" VOCE PERDEU JOGO! RAPOSA E GALINHA SOZINHOS")
cont<-0
                                   senao
                                         se(galinha = milho) e (milho <> voce) entao
                                            cont<-0
                                            escreva(" VOCE PERDEU JOGO! SACO DE MILHO E GALINHA SOZINHOS ")
                                         fimse
                                   fimse

                                   se(galinha = 2) e (milho = 2) e (raposa = 2) e (voce = 2)entao
                                          escreva(" VOCE GANHOU O JOGO!!!")
                                          escreva(" MARGEM ATUAL: ")
                                          escreva(" GALINHA: MARGEM ", galinha)
                                          escreva(" SACO DE MILHO: MARGEM ", milho)
                                          escreva(" RAPOSA: MARGEM ", raposa)
                                          escreva(" VOCE: MARGEM ", voce)
                                          cont<-0
                                   fimse

                            fimse
                             limpatela
                       fimenquanto
                 caso 2
                      escreva("Obrigado por jogar")
                 outrocaso
                       escreva("opcao invalida")
         fimescolha
         cont<-1
      fimenquanto
      limpatela
      escreva("FIM DE JOGO")
fimprograma

Duvidas ou Trabalhos para fazer entre em Contato: Email: marcofernando71@gmail.com

0 comentários:

Postar um comentário