Pages

sexta-feira, 1 de julho de 2016

Sistema de controle de estoque básico usando função e procedimentos

Software para controle de produtos e gerar relatórios de estoque: com uma funcionalidade para cadastro de 10 produtos em vetores com os seguintes dados(código, descrição e quantidade), uma funcionalidade que efetue a entrada em estoque de um produto solicitando o código e a quantidade a serem incrementado, uma funcionalidade que efetue a entrada em estoque de um produto a descrição e a quantidade a ser incrementada, uma funcionalidade que retorne a descrição do produto com a maior quantidade, um menu principal que chegue todas os procedimentos e funções a cima solicitado com o laço ate que o usuário deseja sair.

algoritmo "controleEstoque"
var
   vetCod,vetQtd:vetor[1..3] de inteiro
   vetDesc:vetor[1..3] de caracter
   cont,opc,codMaior:inteiro

procedimento cadastrar()
inicio
      para cont de 1 ate 3 passo 1 faca
           escreva("Informe o codigo do produto: ")
           leia(vetCod[cont])
           escreva("Informe a descrição do produto: ")
           leia(vetDesc[cont])
           escreva("Informe a quantidade do produto: ")
           leia(vetQtd[cont])
      fimpara
fimprocedimento

procedimento cadastrarCodigo()
var
   codigo,qtd:inteiro
inicio
      escreva("Informe o codigo: ")
      leia(codigo)
      para cont de 1 ate 3 passo 1 faca
           se(vetCod[cont]=codigo)entao
                escreva("Informe a quantidade a ser inclementado")
                leia(qtd)
                vetQtd[cont]<- vetQtd[cont] +qtd
           fimse
      fimpara
fimprocedimento

procedimento cadastrarDescricao()
var
   qtd:inteiro
   desc:caracter
inicio
      escreva("Informe a Descrição do produto: ")
      leia(desc)
      para cont de 1 ate 3 passo 1 faca
           se(vetDesc[cont]=desc)entao
                escreva("Informe a quantidade a ser inclementado")
                leia(qtd)
                vetQtd[cont]<- vetQtd[cont] +qtd
           fimse
      fimpara
fimprocedimento

funcao maiorQtd():inteiro
var
   maior,cod:inteiro
inicio
      para cont de 1 ate 3 passo 1 faca
           se(cont = 1) ou (vetQtd[cont] > maior)entao
                   maior<- vetQtd[cont]
                   cod<-vetCod[cont]
           fimse
      fimpara
      retorne cod

fimfuncao

inicio
      repita
            escreva("1-cadastrar Produto 2-Repor estoque por Código 3-Repor estoque por Descrição 4-Produto com Maior Qtd 0-sair")
            leia(opc)
            escolha(opc)
               caso 1
                    cadastrar()
               caso 2
                    cadastrarCodigo()
               caso 3
                    cadastrarDescricao()
               caso 4
                    codMaior<-maiorQtd()
                    escreva(maiorQtd())
                    para cont de 1 ate 3 passo 1 faca
                       se(vetCod[cont] = codMaior)  entao
                            escreva("O Produto com a maior quantidade eh: ",vetDesc[cont],"Unidade: ",vetQtd[cont])
                       fimse
                  fimpara
               caso 0
                    escreva("Saindo...")
               outrocaso
                        escreva("Opção Inválida")
            fimescolha
      ate opc =0
fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: Email: marcofernando71@gmail.com

0 comentários:

Postar um comentário